Google servers error. i have tried three different phones to log in and they are showing the same error

how do you solve this problem[ATTACH=full]161680[/ATTACH]

Airtel, Safcom or Orange?

What is your Android version? It is below 5, right?
I had the same issues a long time ago when I was on Android 4.2 and 4.4

  1. Update Google Play Services, Google, Google Play Store. Especially the Google Play Services, the GP store and the Google App. You can get an update of Google Play Services from since haiko play store.

  2. Uninstall Updates from Google play services and Google Play store then repeat step one. To uninstall them, go to Settings-Apps-Google Play Services/Store.

  3. This is a bit rush but worked every time. Just back up your phone and factory reset the damn thing. It will work for a month before it brings up the problem again. Repeat.

  4. I don’t remember this one very well. Root the phone. Download an app called Host Editor. Go and delete all the host files in it. That should make it start working normally. If it doesn’t, add host addresses from Google again(they are all over the net).

  5. Eka flight mode, restart phone. Washa net tena. Jaribu data kama ni wifi. Sometimes, it starts working magically.

  6. Nunua simu ingine. Preferably Android O (8) upgradeable to P (9). Kama ni kubaya, chukua yenye iko na Nougat 7. 6 Marshmallow ni nzee sana.

its android 5.1. let me try

is it advisable to flash it?

i have tried with safcom airtel and wifi

Deorro how do you embed media here? Since the upgrade inakataa.


attach files to upload the media files on your device
the image icon to embed images and gifs from other sites if you know their url
the media button to embed videos, audio, images from the listed sites ege Youtube, Soundcloud, Apple Music, spotify etc