laptop kuharibika

tech gurus kujeni kiasi.
sasa laptop yangu (lenovo y50-70 touch) crashed and restarted bringing the automatic repair message after showing the BSOD. it then goes blank hadi charge iishe. doesnt boot kabisa
Tried repairing using windows cd ikakata plus windows on bootable usb bado haikusoma.
so i tried with ubuntu on usb in order to access some files so that incase i have to format nisipoteze kitu. this worked and i was able to access my files.
sasa kurudi jioni jana when i turn it on it says " EFI USB Device boot failed". i have tried changing the boot order but ni kama it reverts to the usb as boot device.
nikichange to legacy instead of uefi bado inakataa.
saidieni tafadhali how to sort this shit.
attached is the image.


Reset bios settings and reinstall windows

how do I do that? sioni hiyo part ya kureset elder

I think that’s a bios/boot sector virus though i’ve never encountered one,search for solutions basing on that.

Try soft reset the bios

thts very simple reset bios by enabling them on. na iyo iki kataa just buy a new battery ya bios where by its in built… na lazima utafute specifically na ya laptop yako juu huwa hazi ingiani… na after all that thenk me Latter.

haiya !! bios iko na battery yake separate? will try now that reset imekataa.


kindly elaborate elder

nimegoogle now i understand. kinda explains hii ufala yote imekuwa ikinifanyikia.
locally naweza pata wapi hiyo battery.

Kama u good in hardwarw, remove bios battery fr like a min, it will reset the settings to default, then try reinstalling windows